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Welcome to Global Mapper
Thank you for using Global Mapper, the all-in-one GIS application from Blue Marble Geographics. As you will soon dis-
cover, this unique software offers an extensive collection of spatial data processing tools in an easy-to-use application 
that no GIS professional or map enthusiast should be without.

As you begin to explore the wealth of features and functions in Global Mapper, you will learn that this is a truly remark-
able software tool. Nowhere else will you find a single application that offers the level of file format support, data visu-
alization options, digitizing capabilities, spatial analysis tools, lidar and 3D analysis functionality, and map design 
tools, right out of the box.

At Blue Marble Geographics, we are committed to ensuring our customers are provided with the information and 
resources necessary to effectively use the software they have purchased. To that end, we are pleased to offer a col-
lection of instructional materials to help you get up and running in no time.

This Getting Started Guide is designed to assist with the basic operation of Global Mapper and to help you understand 
some of the commonly used features and functions. For a complete guide to all the software’s capabilities, use the 
Help menu to choose Help… or use the F1 key on your keyboard. If formal instruction or self-training is required, visit 
https://www.bluemarblegeo.com/gis-training/ to find out about currently available programs and resources.
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Installation and Licensing

Installing Global Mapper
The current version of Global Mapper can be downloaded from the following web page:

https://www.bluemarblegeo.com/global-mapper-download/

Choose to download the Global Mapper executable installer. The 64-bit version is the default download and will take 
full advantage of the extra memory available and will improve the performance of the software. Several non-English 
language versions are also available. To install Global Mapper, simply double-click the executable. File installation will 
take no more than a couple of minutes.

Registering Global Mapper
The first time you launch Global Mapper, you will see the Register Global Mapper window. The option you select will 
determine the authorization method and the level of functionality available to you when you run the software.      

Log in with a Blue Marble Geographics account to request a trial license or activate a single-user license from a recent 
purchase (requires an order number). Use the Manage Login link to create a new account or to recover a lost pass-
word.

Offline Activation
Activate using a license file provided to you by email. This 
also displays the computer’s information that can be sent to 
authorize@bluemarblegeo.com to request a license for an off-
line machine.

Connect to a Network License Server
If your company or organization has set up a network licens-
ing system, you can use this option to check out a license 
while you are using the software. When you no longer need 
the license, it can be returned and used by someone else in 
your organization.

Continue without Registering
An unregistered version of Global Mapper offers limited func-
tionality (no support saving or loading workspaces, no export 
options, no 3D Viewer, etc.) and is not intended for data man-
agement or production.

Activating Optional  Extensions
After registering Global Mapper, you will have the option to 
expand the software’s functionality with add-on licenses. 
Unlocking additional functionality requires the purchase of the appropriate license, including a Global Mapper Pro 
license. Extensions are typically developed and registered by third party developers, however a preconfigured exten-
sion called the COAST extension is installed with Global Mapper. This powerful tool is used to analyze the financial 
impact of coastal flooding.

https://www.bluemarblegeo.com/global-mapper-download/
mailto:authorize@bluemarblegeo.com?subject=Global Mapper Offline Activation
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Navigating the Interface
Global Mapper’s user interface has been designed to provide easy and intuitive access to all of the software’s features 
and functions. The key elements of the interface are the menus, the toolbar, and, of course, the map window itself. A 
variety of dialog boxes and floating windows provide access to additional tools or more advanced functionality. 

Menus
The menus in Global Mapper are intuitively organized by function and offer access to all of the features and functions 
in the application. Note that, as with other software titles, there are often many ways to access a particular tool in 
Global Mapper. For example, the action of importing a layer can be performed using the Open Data File option in the 
File menu; the Open Data File button in the toolbar; or by using the Ctrl+O keyboard shortcut. How you chose to per-
form this and other commonly used functions comes down to your personal preference.

The following summarizes the primary function of each menu:

File
The File menu contains all of the options for importing, exporting and saving data. It also includes a list 
of recently imported files, providing convenient access to frequently used layers.

Edit
The primary function of the Edit menu is to enable the copying and pasting of features and to control 
the associated options.
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View
The View menu includes an array of settings for configuring the appearance of 
the interface and of the map itself. There are also options for manually adjust-
ing the zoom level and for saving and restoring a specific map view.

Tools
As its name implies, the Tools menu contains a selection of tools that are used 
to interact with features on the map. Based on the tool that is selected, the 
function of the cursor on the map will change. This menu also provides access 
to certain other dialog boxes such as the Overlay Control Center and the Map 
Layout options.

Digitizer
The Digitizer menu lists many of the feature creation and editing operations 
available in Global Mapper. Based on features that are selected on the map, 
different options in the sub-menus branching off will be available to use. 

Analysis
The Analysis menu consolidates many of the analytical functions into a con-
venient single list. While most of the analysis tools, such as watershed and 
contour generation, focus on working with elevation data, this menu also 
offers access to additional functions including the Raster Calculator and Graph and Chart Manager.

Layer
The Layer menu provides access to a variety of operations that are performed against a layer or layers 
selected in the Control Center. These include attribute joining and calculation.

Search
The Search menu offers several options for querying or editing feature attributes. It also includes an 
address search function that includes geocoding capability.

GPS
When a compatible GPS receiver is connected to your computer, the position can be represented by a 
symbol on the map. The GPS menu controls the configuration and interaction between Global Mapper 
and a connected GPS device.

Help
The Help menu provides a single point of access for the various help options and other resources that 
are available for Global Mapper. For more information.

Toolbars
The buttons on Global Mapper’s toolbars offer the most convenient way to select a tool, to open certain dialog boxes, 
or to switch between one function and another. If necessary, toolbars can be removed from the interface using the 
Toolbars option in the View menu, or can be undocked or moved to another position. Within each individual toolbar, 
buttons can be removed or added as needed.

The following are the buttons in the File toolbar:
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Adding additional map view can help to better display and explore data:

The Favorites toolbar provides a convenient way to access commonly used components of Global Mapper:
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Configuration
The Configuration dialog box can be opened from the Tools menu or by clicking the Configuration button in the toolbar 
and it offers a single location for establishing personal settings and preferences that control many of the features and 
functions of the software.

General
The General options include the 
default units of measurement, back-
ground color and coordinate format.

Vector Display
The function of Vector Display is to 
control the appearance of point, 
line, and area features on the map. 
Specific options include filtering data 
types and adjusting the display 
order.

Display Options
The Display Options are used to con-
figure the display of map elements 
including the scale bar and legend.

Styles
These options are used to create 
and manage feature types that can 
be assigned to polygons, lines, or 
points. Applying a feature type to a 
vector feature will automatically 
adjust the appearance of the feature 
and assign a custom list of attributes 
if required.

Projection
The Projection section is used to alter the coordinate reference information for onscreen display and 
reproject a layer from one system to another before exporting.

3D View Properties
3D View Properties, which is also accessible directly from the 3D Viewer, includes numerous options for 
controlling the behavior and display of the 3D map view. These include vertical exaggeration, back-
ground color, and 3D vector display.

Vertical Options
Vertical Options offers settings that control the display of elevation or terrain layers. These settings 
include the selection of a shader pattern and customization of the hill shading.

Shader Options
Shader Options controls the visual display of several preconfigured elevation and slope shader pat-
terns and allows new patterns to be created.



Copyright Blue Marble Geographics 2022

Lidar
The Lidar settings are used for filtering a point cloud based on classification or return types.

Feature Templates
The function of Feature Templates is to create a set of preconfigured attributes that streamline the pro-
cess of digitizing or data collection, especially when using Global Mapper Mobile.

GPS Options
GPS Options offers several settings for controlling the tracking process when using a connected GPS 
receiver.

While the Configuration dialog box offers access to most of Global Mapper’s preferences and settings options, many 
other components of the software contain feature-specific settings that are established when performing that func-
tion. For example, when exporting a file in a particular format, many of the preferences associated with the exported 
file are set in the Export Options dialog box.
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Layer and File Management

The Control Center
The Control Center is Global Mapper’s layer management tool. It can be 
opened from the Tools menu, by clicking the Open Control Center button in 
the Toolbar, or by using the keyboard shortcut Alt+C. Unlike most other dia-
log boxes, the Control Center can remain open while using other tools in the 
software. The Control Center window can also be docked by dragging the dia-
log box to one of the edges of the map window.

There are two ways in which a layer can be removed from the map display: 
the adjacent box in the Control Center can be unchecked or the selected 
layer can be removed completely by using the keyboard Delete key or high-
lighting the layer and choosing the Close (Unload Layers) button. Using the 
uncheck option, the layer is retained and can be simply checked on again 
when needed. Closing an overlay permanently removes it and any unsaved edits or created features will be lost.

Right-clicking on a selected layer or layers in the Control Center offers a variety of options for managing the layer. For 
instance, the Description or name of the layer can be changed, or multiple layers can be grouped in a tree view. This 
right-click menu also offers access to the Layer Options dialog box, which is used to adjust certain settings pertaining 
to a layer.

The Options Dialog Box
The tabs in the Options dialog box differ depending on the data type contained in the selected layer:

Vector Options
The primary functions of the Vector Options dialog box include man-
aging the display of labels; assigning features to a feature-type cat-
egory; and adjusting the display characteristics of the features in the 
layer (fill pattern, symbol style, etc.).

Raster Options
The Raster Options dialog box includes tools for establishing trans-
parency; adjusting color balance, contrast, etc.; and cropping an image 
to a defined area.

Elevation Options
The available Elevation Options include tools for offsetting elevation val-
ues in the layer and for defining the range of visible elevations.

Each of the Options dialog boxes includes Map Zoom, to control the 
zoom range within which the layer will be displayed, and Layer Pro-
jection tab, which is used to reinterpret the coordinate values asso-
ciated with the selected layer. Adjusting these projection parameters 
will result in the contents of the layer being physically moved to a new 
location and should only be performed when you know the original 
coordinate settings were incorrect. To simply reproject your map, use 
the Projection section in the Configuration dialog box.

Saving the Workspace
The workspace is 
the core file man-
agement com-
ponent of Global 
Mapper. It allows you to store information about the layers that 
are displayed on the map as well as any settings or 
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configuration that have been applied to these layers. At its most basic level, a workspace is a file (*.gmw) that records 
a snapshot of your current map view.

To save your workspace, click the Save button in the toolbar or click the File menu and select Save Workspace... If a 
workspace was not previously saved, you will be prompted to name and choose a location for the file. You can also cre-
ate a duplicate of an existing workspace by using the File > Save Workspace As… option. This function is useful for 
establishing a workspace template, possibly containing all layers or covering the full extent of your area of interest. 
Any workspaces created from this template using the Save Workspace As… command will inherit all of the layers and 
settings from the original and can then be individually modified to reflect the requirements of a particular project or 
job site.

Working with Imported Layers
An important consideration when working with workspace files is that they do not actually contain the map data from 
any files that are imported. Instead, the workspace records the path to the original file location as well as any edits or 
configuration that has been applied to this layer. If the path to the file location is broken, such as when you disconnect 
from your network or when the file is deleted or moved to a new location, the workspace will not load correctly and an 
error message will be displayed. For this reason, workspace files should typically not be shared with other Global Map-
per users, assuming that the path to the included data is unique to the original computer.

Working with Digitized Features
Points, lines, and area features that are created using Global Mapper’s Digitizer tools are stored directly in the work-
space file. Modifications or additions made to any imported data are similarly archived internally within the software 
and are only applied to the original external data using the export function.

Global Mapper Package Files
An efficient way to share data among Global Mapper users is to create a Global Mapper Package file (*.gmp). Unlike 
the aforementioned workspace format, a package file contains all of the map data from any previously imported lay-
ers and it retains all of the configuration settings and edits that were applied to these layers. A single Global Mapper 
package file can contain data in any format (raster, vector, and/or elevation) and as such, it provides an extremely 
efficient tool for exchanging maps and spatial data among Global Mapper users.

Global Mapper Package files also offer a simple way to create backups of important datasets that can easily be reim-
ported in the event of a loss of the original data or hardware failure.
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Importing Data

Supported Data Formats
One of the defining characteristics of Global Mapper is the volume and variety of file formats that can be imported into 
the software. In the current version, over 300 file-types are supported, including all common spatial formats, such as 
ESRI shapefiles, KML files, MrSID imagery, and lidar point clouds. If Global Mapper doesn’t support your data, contact 
Blue Marble and the software development team will determine if the format is compatible. A list of the currently sup-
ported formats is available in the Global Mapper Help pages.

Importing Vector, Raster, and Elevation Layers
There are several ways to import data into Global Mapper: the File > Open Data File(s) command, the Open Data File
(s) button in the File Toolbar; or the Ctrl+O keyboard shortcut. In each case, you will be prompted to browse to the 
required file to initiate the import process.

Most formats of vector, raster, and elevation formats are imported using the same dialog box and the same pro-
cedure. Text files are a common exception that require some additional user input. Global Mapper is able to dif-
ferentiate the various formats and automatically assigns each to the appropriate overlay type. If required, you may be 
asked to define the coordinate parameters, to verify the data format for files with unconventional suffixes, or to 
manual rectify the file if there is no inherent geographic reference information. 

When importing, it is possible to select multiple files by holding down the Ctrl or Shift key while selecting the required 
files in the Open dialog box. Alternatively, you can open all compatible files in a specified folder or directory tree using 
the File > Open All Files in a Directory Tree command.

Finally, and perhaps most conveniently, you can simply drag and drop a compatible file onto the Global Mapper win-
dow to automatically initiate the import process.

Importing Text Files
Text files containing a list of coordinate values can 
be imported into Global Mapper and used to create 
points, lines, or area features. To initiate the text 
file import process, use the File > Open Generic 
Text File(s) command.

After selecting the required file, you will be promp-
ted to assign certain parameters for the imported 
file such as the order and format of the coordinate 
values, the number of header rows in the file, and 
whether or not to import accompanying attributes.

Georectifying Image Files
Global Mapper’s Image Rectifier function provides a 
powerful tool for creating a geographically ref-
erenced raster layer from virtually any image file or 
PDF. The procedure usually involves identifying vis-
ible features in the imported image and tagging 
each of these with their corresponding coordinates.
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To import an image, either use the standard File > 
Open (Ctrl +O) command or File > Rectify  (Geor-
eference) Imagery. If you choose the latter, you have 
the option to directly export the resulting raster file 
after the required control points have been assigned.

After selecting the file to be imported, the Image Rec-
tifier dialog box is displayed showing an overview of 
the image; a zoomed view of the image in which the 
control points can be precisely placed; and a zoomable 
view of the current map. To begin the process, click an 
identifiable point on the image, click the corresponding 
point in the adjacent map, and click the Add Point to 
List button. Repeat this process for several additional 
points spaced as far apart as possible. Alternatively, 
you can manually type the X and Y pixel values from 
the image and/or type the corresponding coordinate 
values derived from surveyed ground control points.

After all of the control points have been assigned, click the OK button to create a new raster layer. To correct any 
errant registration points, select the layer in the Control Center, right-click and choose RECTIFY – Modify Layer Pos-
ition/Projection.

Working with Spatial Databases
As an alternative to importing files, advanced users can establish a direct connection to an existing spatial database, 
which allows Global Mapper to both read and write data directly from the database tables. Among the supported data-
base types are ESRI ArcSDE, ESRI File and Personal Geodatabases, MS SQL Spatial, Oracle Spatial, PostGIS, and Spa-
tialite.

To establish a connection to a spatial database, open the Spatial Database Connection Manager (Tools > Connection 
Manager), click the New button, and enter the required settings. To import data from a connected database, click the 
File menu and choose Open Spatial Database, select the database name, click the Open button, and select from the 
available tables.
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Accessing Online Data

Using the Download Online Data Function
A great way to get started making maps with Global Mapper is stream data from one of the many free online datasets. 
Numerous government agencies, organizations, and commercial companies provide direct streaming access to their 
spatial data archives through Web Map Service (WMS), Web Coverage Service (WCS) and other online protocols. 
Global Mapper includes preconfigured links to many of these servers.

To initiate the download process, click the Online Sources quick-start button on the introductory screen or 
click the Download Online Data button from the toolbar. In both cases, the resulting dialog box will list all of 
the available Data Sources, categorized by type or by geographic area.  After expanding a category list, 
simply select the required data source and set the extent of the data to download using the options at the bot-
tom of the window.

On occasion, you may find that the service that you require is not available and you will see an error message to that 
effect. This circumstance may be due to routine system maintenance, excessive traffic, or other technical issues. 
Unfortunately Blue Marble has no control over the availability of these online map sources so it is recommended that 
you save the data to a local file so you do not have to continually depend on the streamed service. See below for more 
information.

Premium Data Sources
Blue Marble has partnered with several commercial data providers to offer convenient access to high-
quality imagery and elevation datasets. If you select one of the Premium Content options in the Online 
Data Source dialog box, you will be prompted to enter the appropriate log-in details or data access ID 
number to download the data. Information on subscribing to these services can be obtained from the 
data provider’s web site.

Adding Custom Data Sources
While Global Mapper includes numerous preloaded maps services, you can also add custom online 
sources if they are available for your area of interest. Many GIS departments now use the web as an 
efficient delivery mechanism for their datasets and Global Mapper allows you to set up a direct link to 
this data. After clicking the Add New Source button in the Online Data dialog box, simply enter the 
appropriate URL to establish this link.

Saving Data for Use Offline
Because the availability of the streaming data services cannot be guaranteed, it strongly recommended that you save 
a local copy of any online map data. Not only will this ensure that you will always have access to the required layers, 
even when offline, but it will significantly speed up the map draw speed when working with this data.

To save streamed data, click the File menu and select Export > Export Raster/Image Format, choose a file format 
when prompted, and enter the file settings as needed. A good format choice is JPEG 2000 (.jp2) as it provides a bal-
ance between file size and image quality. Before finalizing the export, click the Export Bounds tab in the Export 
Options dialog box and choose one of the available options to limit the geographic extent of the exported file, oth-
erwise you may inadvertently generate an extremely large file. Note that saving data will take considerably longer 
than simply displaying it on the map, so be prepared to wait some time for the file to be saved.
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Using the Digitizer
Arguably the most important tool in Global Mapper, the Digitizer allows you to create, delete, edit, move, reconfigure, 
and copy points, lines, and area features on the map. The most frequently used Digitizer components can be accessed 
directly from the Digitizer (Create) toolbar, but many more tools are available by right-clicking on the map after the 
Digitizer has been enabled.

When used by itself, the Digitizer is a selection tool. After clicking the Digitizer button in the toolbar, the position of 
the cursor is represented by a crosshair with the word EDIT displayed below, and in this mode, points, lines, and area 
features can be selected in preparation for editing, moving etc. Individual features can be selected by simply clicking 
the feature on the map or multiple features can be simultaneously selected by clicking and dragging a box that encom-
passes the extent of the required features or by holding the Ctrl key while selecting multiple individual features.

Drawing Freehand Features
The following buttons are used to manually create vector features on the map:

 Point features or text are created by simply clicking at the required location on the map.

 Line features are created by clicking at each desired shape point on the map. The line is ter-
minated using the right mouse button.

 Trace-mode lines are created by clicking and holding the left mouse button while moving the 
mouse over the map.

 Area features or polygons are created by repeatedly left-clicking on the map. Right-click to add 
the final point, which is automatically connected to the first point.

 Rectangular areas are created by holding down the left mouse button while moving the cursor 
between the opposite corners. Squares are created by holding the Shift button down while dragging.

 Circles are created by holding down the left mouse button while moving the cursor outwards 
from the center point to define the radius. An ellipse is created by holding the Shift button down while 
dragging.

Additional Digitizer Tools 
The Digitizer (Advanced) toolbar contains several buttons for activ-
ating specialized vector creation tools, such as the CoGo tool for cre-
ating line or area features by entering specific dimensions and the 
Range Ring tool for generating concentric circular area features of a specified radius around a point.

The Digitizer right-click menu offers numerous advanced drawing tools that are organized in submenus by type 
(areas, lines, and points) as well as an extensive collection of tools for reformatting, editing, and converting vector fea-
tures.



Copyright Blue Marble Geographics 2022

The Modify Feature Info Dialog Box
The Modify Feature Info dialog box appears after a new feature is created or 
when the right-click > EDIT option is chosen after a feature has been selec-
ted with the Digitizer tool. This dialog box includes options to establish the 
target layer for the feature, style settings, and tools for adding or editing 
attributes.

The Feature Type dropdown list provides the means to assign the selected 
feature to a preformatted classification, which automatically determines the 
visual characteristics as well as the attribute fields that are associated with 
this type. Additional Feature Types can be added to the list by clicking the 
Create New Type button.

Editing Vector Features
Global Mapper provides tools for editing both the geometry and physical 
appearance of vector objects as well as the attributes or information that is 
associated with each feature. Note that modifications made to an imported 
layer are not automatically applied to the source file. Instead, the layer 
must be exported in the appropriate format to apply any edits to a original 
file.

Before initiating any editing function, 
the feature or features must be selected 
with the Digitizer tool as previously 
described. The act of selecting a feature 
activates several additional buttons in 
the toolbar that offer such options as 
moving, rotating, scaling, and con-
verting features. Additional geometric editing options are available by right-click-
ing on the map.

Global Mapper also provides the ability to edit the shape and size of individual 
lines or area features by adding, moving, or deleting vertices or shape points. To 
enable this function, make sure the option to display vertices for selected objects 
(right-click > Options) is enabled. Vertices can then be selected with the Digitizer 
tool and, using the right-click > Vertex Editing function, can be modified in sev-
eral ways.

To restore the original geometric shape or position of a feature, select it with the 
Digitizer tool and choose Move/Reshape Feature(s) > Restore Original Shape of 
Selected Features.

Edits made to vector features can also be undone with the Undo functions in 
Global Mapper. Use the keyboard shortcut ctrl+Z or the Edit menu > Undo Last Operation option to undo recent edits 
to vector features. 

Deleting Features
The easiest way to delete a feature in Global Mapper is to select it with the Digitizer tool and use the Delete key on 
your keyboard. Although the feature will be removed from view, it is not permanently erased and can be easily 
recovered if necessary. Using the keyboard shortcut Ctrl+Z immediately after deleting the feature will undo the dele-
tion. Alternatively, you can toggle the display of all deleted features using the keyboard shortcut Ctrl+Shift+D and, 
using the Digitizer tool, right-click and choose the Undelete option.
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Working with Attributes
The Modify Feature Info dialog box, previously described in the Using the Digitizer section, offers the option to manu-
ally add or edit attributes for one or more selected features. New attribute fields can be created and the corresponding 
values can be manually entered. For large numbers of features, this can be a time-consuming and laborious process, 
so it is typically recommended that attribute fields are automatically applied by assigning them to an appropriate 
Feature Type or, if possible, joining attributes from and external source.

The Attribute Editor
Accessed with the Control Center toolbar button or by right-clicking on one or more layers in the Control Center, the 
Attribute Editor provides a tabular display of all of the attribute data for each layer, separated into individual tabs. 
Within this dialog box, attributes can be queried, sorted, edited, and exported.

Joining and Calculating Attributes
The join process in Global Mapper allows external data to be assigned to the appropriate features in an existing layer 
for the purpose of creating additional attribute fields. Before beginning this procedure, it is essential that each feature 
has an existing attribute that matches a corresponding value in the data being joined. The join can be based on a one-
to-one match, where each entry in the imported data matches one feature on the map, or it can be based on a one-to-
many approach, where an individual record in the data is assigned to several features on the map.

To initiate the join process, click the Join Attributes button in the Attribute Editor. Supported formats for the external 
tabular data include .txt, .csv, and dbf.

The Calculate Attributes function, which is also accessed using a button in the Attribute Editor, is used to create a new 
attribute field by applying a calculation to an existing attribute. Calculation options include standard numeric oper-
ations, such as add and multiply; text-based operations, such as append or prepend text; or advanced formulaic oper-
ations.

Advanced Attribute Options
Global Mapper provides several options for automatically creating or updating attributes. After selecting a feature or 
features on the map with the Digitizer tool, the right-click menu offers an Attributes/Style Functions submenu that 
can be used to automatically assign attributes using a variety of criteria. For instance, with an underlying elevation 
layer, you can assign elevation and slope values to selected features or you can add an attribute with a count of the 
number or point features inside a selected area.
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Using the 3D Functionality
In order to utilize Global Mapper’s 3D functionality, the data with which you are working, must have an inherent elev-
ation or height value. Both vector features and appropriately formatted raster layers can include this “Z” value and 
can be modeled in a three-dimensional perspective.

The most common application for 3D data is to generate a terrain surface, which is the basis of many of Global Map-
per’s analytical functions, such as watershed delineation and flood level modeling. A height value can also be applied 
to a vector feature or to individual vertices that comprise a vector feature, which allows the feature to be extruded 
from a terrain surface.

Where to Find 3D Data
As with the standard raster and vector data formats, there are numerous sources of 3D or elevation data. Global Map-
per’s Download Online Data function provides several preformatted datasets that can be downloaded free of charge, 
or through a subscription to one of the listed data providers. Global Mapper also supports dozens of preexisting elev-
ation formats, such as DEM and Arc/Info Grid files, which are imported using the normal File > Import process. Simple 
text files that include elevation values along with coordinates can be imported using the File > Import Generic ASCII 
Text File(s) command and can be gridded to create an elevation layer. Finally lidar (Light Detection and Ranging) data 
can be imported and processed to create a high-resolution surface model.

 

Creating a Terrain Map from 3D Vector Features
The process of generating a raster elevation layer from an array of vector 
features that contain an elevation value involves gridding the data. This 
procedure typically follows the import of an XYZ text file or lidar file, but it 
can also be performed using other vector files such as contours. To create 
an elevation grid from a selected layer, right-click on the layer in the Con-
trol Center and choose Analysis > GRID or click the Create Elevation Grid 
button in the Analysis toolbar. In both cases, the Elevation Grid Creation 
Options dialog box will appear, which offers a number of options for con-
figuring the gridding process.

3D Options and Preferences
By default, an elevation layer will be displayed using the multi-colored Atlas 
Shader, although there are several additional options in the Shader drop-
down list. A simulated hill shade or shadow effect will also be applied to 
accentuate variations in the terrain. This can be disabled using the Hill 
Shade button. Additional 3D options can be established in the Con-
figuration dialog box.
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Visualizing the Map as a 3D Model
A supplementary map window in Global Mapper 
provides the means to view any data with a 
height or elevation value as a three-dimensional 
model. This window is opened using the 3D View 
button in the Viewer toolbar. This window can 
also be docked adjacent to the corresponding 2D 
map.

Many of the same zooming and panning functions 
that are used in the 2D map view are also avail-
able in the 3D window. Additional tools allow the 
vertical exaggeration to be increased, the per-
spective to be changed to ground level, and water 
inundation to be simulated. The 3D window also 
includes a Save function that allows the current 
3D view to be captured as an image. Additional 
settings for the 3D view can be found in the 3D 
View Properties section of Configuration.

Working with Point Cloud Data
With the availability of 3D data sources and collection methods expanding, more and more point cloud data is being 
used to create highly accurate terrain models, meshes, and other 3D data. Global Mapper works with both lidar  (Light 
Detecting and Ranging) date and photogrammetrically derived point cloud data. In its native format, this is a series of 
closely-spaced points, each of which contains precise coordinates, an elevation, possibly a classification that denotes 
the type of feature that the point represents (ground, vegetation, building, etc.), and several additional attributes. 
Recent developments in Global Mapper have expanded support for both the standard lidar files (.las and .laz) as well 
as other point cloud formats. Global Mapper Pro offers advanced lidar processing tools. 

Lidar data is imported using the standard import procedure (Ctrl+O) however the subsequent import options dialog 
box is unique to this format. In this window, the data can be filtered, sampled, and if required, can be directly gridded 
into an elevation layer.

After importing, the points will inherit the colors of the currently selected shader and will reflect the elevation value if 
no RGB values have been assigned to each point. Using the layer’s Options dialog box, the display of the points can be 
changed to represent other variables such as classification or intensity. Also unique to this format is the Edit function, 
which is accessed by right-clicking after selecting one or more of the lidar points with the Digitizer. In this dialog box, 
the point’s classification can be edited and other attributes modified.

3D Analysis Functions
Global Mapper offers several analysis tools that utilize loaded elevation or terrain layers.

Watershed Modeling
This tool is used to delineate the potential for the terrain to support the flow of water using linear fea-
tures to represent stream channels and area features to outline watersheds or catchment areas.
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Path Profile/Line-of-Site
A Path Profile is a cross-sectional view of the terrain as represented by a line feature. The Line-of-Site 
analysis, which will only work with a single segment line, shows where obstructions impede the view or 
transmission path from one end of the line to the other.

View Shed Analysis
The View Shed tool outlines which areas are visible or are within the broadcast range of defined loc-
ation. Options such as azimuth range, distance, and height of the point of origin can be customized in 
the view shed analysis setup dialog box.

Water Level Rise/Flood Simulation
Based on a selected area or on actual sea level, the Water Level Rise/Flooding tool outlines those areas 
that will be impacted by a specified increase in water level.

Contour Generation
The creation of contour lines is one of the most common uses for elevation data in Global Mapper. The 
Contour Generation Options dialog box allows the contour interval to be established, supplementary 
areas features to be created, and other settings to be applied.

Calculating Volume Between Surfaces
With two overlapping elevation layers loaded, such as a surface layer and a subsurface bedding plane, 
this straightforward tool calculates the volume of material between the two.

Comparing/Combing Terrain Surfaces
This tool creates a new elevation layer from an operation or calculation applied to the elevation values 
in two overlapping layers. Operators include subtraction, average and maximum.

Cut and Fill Calculation
Available as a right-click option when either a line or area feature has been selected with the Digitizer, 
the Cut and Fill calculation tool determines the volume of material that will need to be removed and/or 
added to create an artificially flattened surface.

Assigning Height or Depth to Vector Features
Any point, line, or area feature can have an associated z-value, which allows it to be modeled in a 3D environment rel-
ative to other vector features or to a loaded terrain surface.

When importing a vector layer, Global Mapper will automatically look for an existing vertical attribute, such height or 
elevation, and use that as the z-value. To manually assign a z-value, simply add a new attribute to the required 
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feature or features and type the elevation, height, or depth. To make sure Global Mapper recognizes this attribute as 
a z-value, open the Options dialog box for the layer in the Control Center and choose the appropriate attribute field 
from the Get ‘Elevations’ from Attribute Value dropdown list in the Elevations tab.

It is also possible to add a unique z-value to each vertex that comprises a line or area feature. This procedure is ini-
tiated by clicking the Vertices button in the Modify Feature Info dialog box for a selected feature.

Working with 3D Models or Meshes
Global Mapper supports several 3D Model formats including OBJ, 
DAE, and STL files.  These are rendered as top-down vector features 
in the 2D map view but assume their full 3D characteristics when dis-
played in the 3D View. Using Global Mapper Pro, 3D models can be 
created from selected points in a point cloud layer or as a by-product 
of the Pixels-to-Points tool. 

Creating a 3D Fly-Through Recording
Global Mapper 
provides a simple 
tool for creating a 
video file that records a user-defined path through any 3D envir-
onment. The process of creating the path is initiated with the Digit-
izer tool and can use a drawn line, imported line feature, or GPS 
track file. The line itself does not have to contain any particular 
characteristics or attributes but is simply used to define the course 
of the flight.

After selecting the line, the Create 
Fly-Through button will be avail-
able in the Analysis toolbar. Click-
ing this button opens the Fly-

Through Path Properties dialog box, in which the flight settings are 
established. These settings include height above ground, flight dur-
ation, camera angle, and pitch.

In the 3D Viewer, a series of buttons control the preview, playback, 
and recording of the video file.
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Using Global Mapper Pro
Global Mapper Pro is an optional add-on component of the software that opens up a suite of advanced functionality 
including tools for lidar and point cloud processing, advanced terrain analysis, script editing, and Python scripting.

Activating Global Mapper Pro
Global Mapper Pro is installed with the standard version of Global Mapper however a valid registration key is required 
to activate it. This key can be ordered on the Blue Marble website or it can be added to your original purchase. To activ-
ate Global Mapper Pro, use the Help menu to choose the License Manager. Simply checking the box next to the Global 
Mapper Pro will trigger the registration window. After activating the license, the Global Mapper Pro functionality will be 
immediately available.

Lidar and Point Cloud Functionality
A key feature of Global Mapper Pro is a set of toolbars that include buttons for reclassifying point returns, applying fil-
ters, extracting vector features from a point cloud, and creating a point cloud from overlapping aerial images. Behind 
the scenes, Global Mapper Pro significantly improves the performance of point cloud related processes and offers sev-
eral visualization options including cross-sectional viewing and editing of a swath of points.

 

Manual classification of points can be applied to selected 
points with buttons from a third toolbar in the 2D and Path Pro-
file/LOS views.

Photo Generated Point Clouds and Models
The Pixels to Points® tool uses photogrammetry methods to create 3D point clouds, orthoimages and/or photo-tex-
tured 3D Models from overlapping images. Ideally suited for UAV or drone operators, Pixels to Points analyzes the rela-
tionship between recognizable objects in adjacent images to determine the three-dimensional coordinates of the 
corresponding surface.

To create a point cloud, simply click the Pixels to Points button and load your images into the resulting dialog 
box. Apply the necessary settings and add ground control points if available before clicking the Run button.
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The Pixels to process is intensive and may take some time to process depending on the input data, quality settings 
applied, and machine memory and resources available.

 

Advanced Analysis

Terrain Painting for manually altering digital terrain models.

Automatic Breakline Extraction to create vector line features at distinct changes in elev-
ation/slope.

A Vectorize Raster tool to extract and smooth vector areas from raster image and terrain layers.

A Variography and Kriging tool allowing customization of the variogram plot and selection of a the-
oretical model to generated a kriged prediction layer.



Copyright Blue Marble Geographics 2022

Scripting Tools

Script Editor dialog with syntax coloring for building, editing, and running Global Mapper and Python 
scripts.

Python programming language integration.

Script Builder tool to record actions take in the program interface as a Global Mapper Script.

Mobile Data Management

A tool for wireless data transfer to and from  devices using Global Mapper Mobile, along with Pack-
age File Import capabilities for merging data layers from multiple Global Mapper Mobile Package 
(*.gmmp)files. 
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Exporting and Printing Maps
Efficient file exporting and map sharing are essential components of any GIS and play a major role in the functional 
makeup of Global Mapper. Just as the software can support a vast array of file formats for importing, similarly hun-
dreds of file-types can be exported ensuring Global Mapper’s interoperability with many third-party applications.

When exporting data from Global Mapper, there are several issues and factors that need to be taken into account:

All compatible layers and/or visible features will be exported by default. In other words, Global Mapper will cre-
ate a single file for all displayed layers by merging multiple layers into one file. In order to export the contents 
of a specific layer, right click on the required layer in the Control Center and choose Layer > EXPORT.

There is no automated process for saving edits or additions to an imported file. In order to save changes to the 
source file, you need to export the layer in the same format and overwrite the original file.

The projection and coordinate settings for any exported data are established in the Projection tab of the Con-
figuration dialog box. Regardless of the projection parameters of each imported layer, this global projection 
will be assigned to all exports.

Each export format’s options dialog box has a set of format-specific settings that are applied to the file being 
exported. Common to all formats are an Export Bounds option, that can be used to limit the geographic extent 
of the data being exported, and a Gridding or Tiling option that can be used to break up a single large file into 
several smaller files.

Exporting Global Mapper Package Files
When sharing data with other users of Global Mapper, the Global Mapper 
Package format is the preferred choice. This proprietary format supports all 
compatible data-types and allows multiple layers to be simultaneously trans-
ferred in a single compressed file. When imported, the Global Mapper pack-
age file will recreate the layer structure of the original data.

Global Mapper package files can also be employed as a means for backing up 
critical datasets. This ensures that the data can be effectively restored in the 
event of a loss of the original data or hardware failure. To create a package 
file, click the File menu and select Export > Export Global Mapper Package 
File…

Exporting Vector, Raster, and Elevation Layers
Unlike Global Mapper’s import process in which a single Open command is 
used to access all compatible data, exporting requires the selection of a data 
type (vector, raster, or elevation) and subsequently a specific file format. 
The Export submenu under the File menu offers these three options. The 
selection of a format for the exported data will depend on the intended use of 
the resulting file and its compatibility with the third party software into which 
it will be imported.

Exporting to a Spatial Database
In the same way that Global Mapper provides a streamlined way to import 
data from a spatial database, any loaded data, regardless of its origin, can be written out to any of the supported data-
base formats. As when exporting data in file format, the Export submenu provides three database export options: ras-
ter, vector, and elevation. 

Uploading Maps to an Online MangoMap
MangoMap is an online mapping service that provides a simple and efficient way to share geospatial data with anyone, 
on any device. Beginning in version 21, Global Mapper users can set up a MangoMap subscription and publish map dir-
ectly from the software. To initiate the process, click the MangoMap button the toolbar.
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Printing the Map
Before sending a map to a connected printer, Global Mapper offers a powerful page layout tool that can be used to add 
cartographic elements such as a title, legend, and scale bar to the map. Using a what-you-see-is-what-you-get 
approach, the Map Layout Editor simplifies the production individual maps or map books.

Creating a Geospatial PDF
Capturing a map view as a Portable Document Format (PDF) allows the 
map to be shared with virtually anyone, regardless of their computer’s 
operating system. Global Mapper’s PDF export function also retains the 
inherent layering structure and geographic referencing information so 
that the map viewer can turn on and off layers as needed, can see the 
coordinates when their cursor is moved over the map, and can perform 
simple cartographic functions such as measuring distances.

Exporting a PDF is similar to sending a map to a printer and includes 
many of the same setup options. To create a PDF, click File > Export > 
Export PDF File… Additionally, a geospatial PDF can be created in the Map 
Layout Editor window.

Capturing a Screenshot
Perhaps the simplest way to share a map, the Capture Screen Contents to 
Image command is an available option in the File menu or by using the 
Shift+C keyboard shortcut. The resulting dialog box offers the choice of 
four common image formats and includes an option to save a projection 
and/or world file that will allow the image to be imported into a third party 
GIS application.
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Where to Find Help

Global Mapper Help Documents
Global Mapper’s searchable help system is automatically installed with the software 
and is accessed from the Help menu or by clicking the F1 key. You can either browse 
through the contents section or search for a keyword to find information on the func-
tion in question. Embedded hyperlinks help you navigate between sections and 
provide supplementary information about the selected topic.

Online Resources
An online version of the complete User’s Manual is available here.

Recordings of the Global Mapper webinar series, which cover a variety of topics in the 
software can be viewed on the Blue Marble YouTube channel.

The Global Mapper Forum
The Global Mapper Forum is an active online community of users and experts from a 
wide variety of industries and fields. Forum participants have the opportunity to ask questions, offer tips, and par-
ticipate in discussions about the use of the software and its future development. Many new users find browsing 
through the posted topics to be an invaluable part of their learning experience.

A link to the Global Mapper Forum is available in the software’s Help menu or you can navigate directly to the fol-
lowing site: www.globalmapperforum.com

Training Opportunities
Both public and company-specific training opportunities are available to help you get the most out of the software. 
The availability of scheduled public classes and information about registering is posted here: https://www.blue-
marblegeo.com/gis-training/public-gis-training/

Customized on site or online classes can also be arranged for individual companies or organizations. For information, 
email:

training@bluemarblegeo.com

Global Mapper Support
After all other self-help options have been tried, on-demand support is available to resolve any issues with the install-
ation, registration, or performance of the software. Support requests are initiated using the preconfigured form on the 
following web page: https://www.bluemarblegeo.com/forms/support.php

https://www.bluemarblegeo.com/knowledgebase/global-mapper-22-1/GlobalMapper.htm
https://www.youtube.com/user/BlueMarbleWebinars
http://www.globalmapperforum.com/
https://www.bluemarblegeo.com/gis-training/public-gis-training/
https://www.bluemarblegeo.com/gis-training/public-gis-training/
mailto:training@bluemarblegeo.com?subject=Custom Training Inquiry
https://www.bluemarblegeo.com/forms/support.php
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Useful Keyboard Shortcuts

General Application
Open the User Guide F1
Display 3D Window Ctrl+3
Print Ctrl+P
Exit Global Mapper Alt+X

File Management
Open data file (import) Ctrl+O
Save the current workspace Ctrl+S
Load a workspace Ctrl+W
Unload (remove) all layers Ctrl+U
Copy selected features to the clipboard Ctrl+C
Delete and copy selected features to the clipboard Ctrl+X
Paste features from the clipboard to a selected layer Ctrl+V
Open the Overlay Control Center Alt+C

Tools Selection
Digitizer Tool Alt+D
Feature Info Tool Alt+P
Measure Tool Alt+M
Zoom Tool Alt+Z

Zooming and Panning
Zoom in Page Down
Zoom out Page Up
Zoom to full extent of all loaded data Home
Pan the Map (¼ screen increments) Arrow Keys
Pan the Map (Entire screen) Ctrl+ Arrow Keys

Digitizer Functions
Edit the feature under the cursor Left Double-Click
Select a feature and automatically enter move mode Alt+Left Click
Undo Last Operation Ctrl+Z
Cancel the current operation Esc
Delete the selected feature Delete
Undelete the selected feature Shift+Delete
Temporarily disable snapping when drawing a feature Alt+Left Click

Custom Keyboard Shortcuts
Additional keyboard shortcuts can be manually assigned using the Favorites dropdown list in the toolbar. 
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How do I...?

How do I register Global Mapper?
After installing Global Mapper, launch the software and you will see the Register Global Mapper widow. If you pur-
chased a license, enter your account information as prompted to unlock the full functionality.

How do I reproject a layer?
Open the Configuration dialog box (Tools > Configure), select the Projection section and update the projection and 
coordinate parameters as needed. These settings will be applied to all loaded data and will be applied to exported lay-
ers.

How do I change the background color of the map window?
Click the View menu and choose Background Color... The selected color will be saved in the current workspace.

How to I recover a deleted feature?
Use the Ctrl+Shift+D keyboard shortcut to toggle the display of deleted features. Select the required feature with the 
Digitizer tool, right-click on the map, and choose Undelete to restore the feature to its original state. Alternatively, use 
the Ctrl+Z keyboard shortcut right after deleting the feature.

How do I add text to the map without an accompanying symbol?
Select the New Point tool from the Digitizer (Create) toolbar and click at the location of the map where you would like 
to place the text. In the resulting Modify Feature Info dialog box, type the text you would like to add in the Name field 
and choose Text from the Feature Type dropdown list.

How do I save map layers from an online data source for offline use?
After the required online data is displayed on in the map window, click the File menu and choose Export > Export 
Raster/Image Format. In the Export Options dialog box, make sure the Export Bounds settings match the geographic 
coverage requirements. Leaving the default All Loaded Data may result in an extremely large file and increase pro-
cessing time. After the export process is complete, close the connection to the online data in the Overlay Control 
Center and import the previously exported file.

How do I automate data processing tasks in Global Mapper?
There are several tools that can be employed to streamline certain data processing tasks. In the File menu, the Batch 
Convert/Reproject command can be used to collectively translate multiple files of a specific type into another format 
and/or to reproject the data to another coordinate system. Scripting can also be used to automate multiple tasks in a 
workflow. A script is a simple text file that contains a series of commands and associated parameters for importing, 
processing and exporting data. For more information on scripting go to the following web page: www.blue-
marblegeo.com/knowledgebase/global-mapper/ScriptReference.html
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